基于本地测试环境搭建安装一个基本的OpenCart4.0项目

最后更新于:2023-04-03 11:35

本篇基于掌握PHPSTORM/IDEA等开发工具,并且已经配置了最基本的php使用环境。

搭建基础环境和系统配置:

书写此篇博文时,OpenCart已经更新到4.0以上版本,要求PHP8.0以上开发环境。此外要求PHP开启GD Library ,Mbstring,OpenSSL Encrypt,ZipArchive,Zlib等。 如果缺少开启对应的配置,会在一开始install时报错提示。此时,需要对应在php.in文件中开启或增加如上配置即可。

如上版本不匹配哦,php需要升级到8以上。

下载OpenCart安装包并进行安装操作:

首先在opencart官方网站或者直接在GitHub上下载最新的源码包:

1.前往官网下载:https://www.opencart.com/index.php?route=cms/download

点击击右侧的 Download Now 绿色按钮,下载zip压缩包到本地,解压后打开项目。

2.使用GitHub下载:

GitHub地址:https://github.com/opencart/opencart  

点击Code 按钮,克隆到本地打开项目,或者下载成ZIP文件,解压后打开项目。

其次,使用编辑器打开opencart项目,并进行安装

根目录下分为几个阅读md文件,和upload文件夹,编码内容位于upload文件夹下。

使用upload文件夹下,index.php 作为安装入口文件打开,项目进入安装阶段:

接着下一步,页面会提示你当前的配置是否合适或者缺失。

如下图:


第二项提示需要安装的ext扩展内容,标记为X的项目需要取去php.in文件中打开:

搜索对应扩展项,去掉前面的注释分号:

extension=curl
extension=openssl
extension=gd

第三项提示需要最基本的配置文件,如果状态status是Missing,表明没有对应的配置文件,

此时将文件目录 upload,upload/admin下的两个config-dist.php 修改文件名config.php文件。或者直接在两个文件路径下各自创建一个新的空文件:config.php。

完成以上配置后,重启项目,再次来到该页面,没有标记为红色背景行,此时进行下一步:

数据库配置填写

第一项为数据库配置

第二项是创建用户信息



到此,基本的配置项完成。

进入页面项,如果满屏幕的warning警告,使用8.2版本会出现这个情况。那么记得将php版本调整为8.0即可。

从upload/admin/index.php 进入,是后台管理页面:

后台是英文的,当然有对应的语言包,更换为中文即可。可以参看文末另外一篇使用语言包的。

从upload/index.php 进入,是前台展示页面:



已经自带了基本的电商功能,和wordpress相比,一步到位。

如果但从电商方面来讲,opencart真的是比wordpress方便很多的,看来,酒香也怕巷子深啊。

只是很可惜,openCart的地址,从最开始和WP一样火爆,到近几年慢慢冷淡了下来。不得不说周边配套很重要,不论是开源平台还是一门语言,拥有一个活跃的圈子,才能推动它一路迭代更新走下去!




相关链接:

Opencart4如何设置中文简体语言包

创建于2023-03-27 22:35 193 阅读